1
Posted October 2, 2013 by Simon in News
 
 

Barclays Mobile Banking and iOS7

barclays_ios_app_82barclays_pingit_ios_app_82

Following the recent release of Apple’s iOS 7, Barclays are advising that iPhone or iPad users need to upgrade their Barclays mobile banking app BEFORE installing iOS 7.  No doubt this will catch a lot of users out as it’s not something you’ll think about doing before taking the upgrade to iOS7, and Barclays have not advised customers directly.

Please make sure you upgrade and log in to the latest version of the Barclays Mobile Banking app (v1.5.2 on iPhone, v1.2.1 on iPad) and Barclays Pingit (v1.11 on iPhone) before you install iOS7.

We’ll post updates once we hear from Barclays on the progress of their next version, as there must be a lot of users on iOS 7 who can no longer use the Mobile Banking and PingIt apps.

Some of the user feedback on the app iOS7 issues so far:

“Letting us know 24 hours too late that you have to upgrade and log in before downloading IOS7 is not good enough!”

“Let down by Barclays broken update”

“First update last week completely killed the app”


Simon